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Drawing Basics 

 

Key points 

• This module presents the basic skills 
required to draw molecules and reactions 
in MDL Draw. 

• If you are drawing structures to be used 
as search queries, there are search-
related properties that you will need to 
add to your structures.  Learning how to 
apply search properties will be covered 
in the appropriate searching courses.  
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Module objectives

Draw molecule structures efficiently

Build reactions from component molecules

Know where to find more information as needed

 

Key points 

• MDL Draw has many flexible drawing 
tools, so there are several ways to 
accomplish any given task.  The method 
you use will be one of personal style.   

• Our goal is to show some of the most 
efficient drawing pathways so that you 
can draw molecules and reactions 
quickly.   

• Where applicable, we will briefly touch 
on some of the other tools, to promote 
awareness of other options.  However, 
the online help offers instructions on all 
tools and methods, so that you can 
explore these topics on your own. 
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MDL Draw interface

 

Key points 

• As you rest the cursor over any tool, a 
tool tip displays the name of the tool or 
brief instructions. 

• The online help will display information 
about the currently selected tool.  To 
find help on other topics, click A-Z in 
the help pane. 

• You can resize the help pane by 
dragging the bar on the left side of the 
pane. 

• To close the help pane, click the Close 
button (x), choose Help > Show/Hide 
Help, or press F1. 
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All-Purpose Drawing tool

Use the All-Purpose Drawing tool to:
Draw atoms, bonds, and chains
Pull out a ring
Change atom or bond type  
Change atom or bond properties 

 

Key points 

• You can use this single tool to perform 
almost all of your drawing needs. 

• You can use the All-Purpose Drawing 
tool to draw atoms, bonds, chains, and 
rings. 

• You can click to select an atom, or shift-
click to select multiple atoms, and then 
perform a drawing operation on the 
selected atoms. 

• You can click a bond to change its bond 
order. 
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Draw omeprazole

1

2

3

 

Key points 

• To draw omeprazole using the All-
Purpose Drawing tool, begin by drawing 
a six-membered ring.  To obtain the 
same orientation as shown on the slide, 
start the first bond by dragging 
horizontally.  When the ring is complete, 
pull the 5-membered ring from the ring 
bond. 

• Draw the additional bonds by dragging 
the All-Purpose Drawing tool.  Create 
double bonds by clicking single bonds. 

• Shift-click to select the nitrogen atom 
positions.  Then right-click, choose 
Atom Symbol, and click N.  (Or, select 
the atoms, and then type N from the 
keyboard).  Repeat for the oxygen atoms 
and  sulfur atom.  
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Right-click menu options

All-Purpose Drawing tool

Right-click
atom menu

Right-click
bond menu

 

Key points 

• Several options for changing atom and 
bond properties are available from the 
right-click menu. 

• When you right-click an atom with the 
All-Purpose Drawing tool, a menu for 
applying atom properties appears. 

• When you right-click a bond with the 
All-Purpose Drawing tool, a menu for 
applying bond properties appears. 
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Other drawing tools

Atom tool

Properties tool

Bond tools

Chain tools

Stereo bond tools

 

Key points 

• All of these tools have right-click menus 
that allow you to change additional 
atom, bond, or molecule properties. 

• A down arrow next to a tool indicates a 
tool palette.  Click the arrow to display 
the palette, and then choose the tool you 
wish to use. 

• With any of the Bond tools, you can 
drag to draw a bond at any angle. 
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Erasing atoms and bonds

Eraser tool

Delete all objects

Undo drawing steps

Redo drawing steps

 

Key points 

• To delete a bond or atom, click it using 
the Eraser tool.  When you delete an 
atom, the Eraser tool automatically 
deletes any attached bonds.   

• To delete a fragment or entire structure, 
drag the tool to encircle the object. 

• You can also delete any selected object 
by pressing the Delete key. 

• To delete all of the objects in the 
drawing area, click the Clear All button.   

• Use the Undo button to successively 
undo the last drawing steps.   

• Use the Redo button to successively 
redo steps that were undone. 
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Using templates

Template Directory Default template tools

Click to place 
the template

Click a bond to 
fuse the template

Click an atom to 
sprout the template

Toolbar Manager

 

Key points 

• Templates are predrawn fragments that 
you can add to your structure. 

• The default templates are displayed as 
tools along the top menu bar.  The 
Toolbar Manager lets you change to a 
different tool bar.  The Template 
Directory provides access to a library of 
templates.   

• After you select a template tool, click 
the drawing area to place an isolated 
template.  

• Click a bond to fuse a template. 

• Click an atom to sprout a template. 
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Using the Template Directory

 

Key points 

• The Template Directory contains several 
folders of templates. 

• Click a folder to display the templates 
contained in the folder.  

• Click a template to select it for use.  
Then click the drawing area to place the 
template. 

• Click the Close button to close the 
Template Directory window. 
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Building reactions

Arrow toolPlus tool

 

Key points 

• To build a reaction, draw the reactants 
and products. 

• Use the Plus tool to place a plus sign 
between multiple reactants or multiple 
products. 

• Use the Arrow tool to place an arrow 
between the reactants and products. 

• This is the reaction that you will build.  
In the process of building the reaction, 
we will be introducing some additional 
molecule drawing techniques. 
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Duplicating structures

1.  Draw molecule. 3.  Choose Edit > Duplicate.

4.  Drag duplicate to new location.2.  Select molecule.

Lasso

Select

Molecule Select

 

Key points 

• To begin, you will draw the first reactant 
structure, and then duplicate it to use for 
the product structure. 

• To duplicate a molecule, you need to 
select it.  There are three different select 
tools available on the tool palette. 

• After you select the reactant, choose Edit 
> Duplicate to duplicate the structure.  
Drag the duplicate to the right side of the 
drawing area. 
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Apply stereo bonds.

Adding stereo bonds

Draw new bonds, change bond 
order, add atom symbols.

Up

Down

Either

Double Either

 

Key points 

• To create the product structure, we need 
to modify the duplicate structure by 
drawing new bonds, changing bond 
order, and adding atom symbols.  You 
can use the All-Purpose Drawing tool to 
perform these operations. 

• There are four stereo bond tools on the 
tool palette. 

• You can use the All-Purpose Drawing 
tool to add the stereo bonds by using the 
right-click menu, but you will have more 
control of the stereo bond direction by 
using the Up Wedge tool. 

• With the Up Wedge tool, you can click 
an up bond to change its direction. 
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Saving a molecule or reaction

File > Save As

 

Key points 

• You can save molecules and reactions in 
external files called molfiles and 
rxnfiles. 

• The files can then be read by other 
structure-based applications. 



Drawing Basics     1 - 15 
 

Notes 

   

   
 
   
 
   
 
   
 
   
 
   
 
   
 
   
 
   
 

Summary

In this module, you learned how to:

Draw bonds and atoms using different tools
Erase atoms and bonds
Undo and redo drawing actions
Use templates
Select, duplicate, and move structures
Build reactions
Save molecules and reactions

 

Key points 

• You learned how to use the All-Purpose 
Drawing tool with its right-click menus 
to draw complete structures and change 
atom and bond properties. 

• You also worked with some of the other 
drawing tools and used predrawn 
templates. 

• You learned how to erase objects, and 
how to undo and redo drawing actions. 

• In building the sample reaction, you 
learned how to select, duplicate, and 
move structures. 

• And you learned how to save molecules 
and reactions in external files for future 
use. 
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The following descriptions explain the goal of each exercise.  
If you like to figure things out on your own, use the 
descriptions to conduct the exercises.  If you prefer step-by-
step instructions, go to the page listed below the description.  
 
 
Draw the following molecule and save it as a molfile. 

N
O

O

O
N

 
 

For a step-by-step solution, see page 1-17. 
 
 
Draw the following reaction and save it as a rxnfile.   
 

O

Br
N

O
S

O

N

N
N

O

O
S+

 
 
For a step-by-step solution, see page 1-19. 
 

Exercise descriptions 

Exercise 1 

Exercise 2 
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Draw oxaziridine 

Draw the following molecule and save it as a molfile. 
 

N
O

O

O
N

 
 

 
1. Click the benzene tool, and then click the drawing area 

to place the ring. 

2. Click the cyclopropane tool, and then click an atom on 
the benzene ring to sprout the three-membered ring.  

 

3. Click the All-Purpose Drawing tool.  Drag to draw the 
bonds for the nitro group.  Click the single bonds to 
change them to double bonds. 

 

4. Click the Single Bond tool.  Drag to draw the bonds for 
the tri-methyl group.  Using the Single Bond tool lets 
you draw bonds at any angle. 

Exercise 1 

Draw the rings  

   

 

Draw the additional bonds 
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5. Click the All-Purpose Drawing tool.  Shift-click to 
select the oxygen atom positions.  Then type O. 

6. Shift click to select the nitrogen atom positions.  Then 
type N.  Press Enter. 

O
N

N
O

O  

7. Choose File > Save As.  Enter oxaziridine as the file 
name.  Click Save. 

 

Add the atoms 

Save the molecule 
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Draw a reaction 

Draw the following reaction and save it as a rxnfile. 
 

O

Br
N

O
S

O

N

N
N

O

O
S+

 
 
 
1. Delete the previous query. 

2. Use the All-Purpose Drawing tool to draw the bonds 
for the two reactants. 

 

3. Click the appropriate bonds to change them to double 
bonds. 

Exercise 2 

Draw the reactions 
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4. Shift-click to select the atom positions for the oxygens.  
Right-click one of the selected atoms, and choose Atom 
Symbol.  Click O. 

5. Repeat to place the nitrogen atoms and the sulfur and 
bromine atoms. 

O

Br
N

O
S

O

N

 

6. Click the Plus tool.  Click the drawing area between the 
two reactants to place the plus sign. 

7. Click the Arrow tool.  Click the drawing area to the 
right of the second reactant. 

Place the reaction symbols 
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O

Br
N

O
S

O

N
+

 

8. Click the benzene template, and then click the drawing 
area to the right of the arrow.  Click the shared bond to 
fuse two more benzene rings. 

 

9. Click the All-Purpose Drawing tool and draw the rest 
of the bonds. 

 

10. Add the nitrogen, oxygen, and sulfur atoms. 

Draw the product 
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N
N

O

O
S

 

11. Choose File > Save As.  Enter reaction1 as the file 
name.  Click Save. 

Save the reaction 
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1. Click the All-Purpose Drawing tool.   

2. Choose a task from the table, and follow the instructions 
given. 

To Instructions 

draw a bond 

draw an atom

draw a chain or ring 

pull out a ring 

change bond order 

change atom type 

change multiple atom 
properties 

change multiple bond 
properties 

Drag at the desired angle 

Click the screen and type a symbol 

Drag the cursor away from an atom 

Press the bond, and drag outward 

Click the bond 

Right-click the atom, and click Atom symbol 

Shift-click to select multiple atoms, and right-
click to change a property 

Shift-click to select multiple bonds, and right-
click to change a property 

 

 

1. Select a bond tool from the tool palette.  (Click the arrow 
next to the bond tool to display the tool palette.) 

2. Drag the mouse to draw the bond at the desired angle. 

1. Click the Eraser tool. 

2. Click an atom or bond to delete it, or drag the cursor to 
enclose the objects you want to delete. 

1. Click Clear All. 

1. Click Undo. 

2. Repeat as needed to successively undo previous drawing 
operations. 

1. Click Redo. 

2. Repeat as needed to successively redo previously undone 
drawing operations. 

To use the All-Purpose 
Drawing tool 

 

To draw a bond at any 
angle  

 

To delete an object 

 

To delete all the objects in 
the drawing area 

To undo a drawing 
operation 

To redo a drawing 
operation 
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1. Select the object(s). 

2. Drag to move the object in the desired direction. 

1. Click the template tool. 

2. Click to place the template in the drawing area. 

1. Click the template tool. 

2. Click the shared bond to fuse the template. 

1. Click the template tool. 

2. Click an atom to sprout the template. 

1. Click the Template Directory. 

2. Click a folder to display the templates contained in the 
folder.  

3. Click to select the desired template. 

4. Click the drawing area to place the template; click a bond 
to fuse the template; click an atom to sprout the template. 

1. Draw the reactants and products. 

2. If there are multiple reactants or products, click the Plus 
tool and then click the drawing area to place a plus sign 
between the reactants or products. 

3. Click the Arrow tool.  Then click the drawing area to place 
the reaction arrow between the reactants and products. 

1. Click the Molecule Select tool. 

2. Click the molecule. 

To move an object 

To place a template 

To fuse a template 

To sprout a template 

To use the Template 
Directory 

 

To build a reaction 

 

 

To select a molecule 
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1. Select the molecule. 

2. Choose Edit > Duplicate. 

 

 

1. Select the molecule. 

2. Drag the molecule to its new location. 

1. Click the All-Purpose Drawing tool. 

2. Right-click the bond and choose the Stereobond option. 

– Or – 

1. Choose a stereo bond tool from the tool palette. 

2. Click an existing bond to change it, or drag to draw a new 
stereo bond. 

3. If needed, click the stereo bond to change its direction. 

1. Choose File > Save As. 

2. Type the name of the file. 

3. Click Save. 

 

To duplicate a molecule 

To move a molecule 

To add stereo bonds 

 

 

To save a molecule or 
reaction 




